[lkml]   [2012]   [Feb]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs
    * Ingo Molnar ( wrote:
    > > [...] so we are going to have to change either the branch site
    > > or the test for true/false name. The above
    > > 'static_key_inline_true/false' solves that.
    > It's generally good practice to make the mostly commonly used
    > method names the simplest/shortest names - i.e. I don't think we
    > should make it longer via adding an _inline to every use.
    > In that sense static_key_true() has pretty optimal length - we'd
    > like these tests to also be visually unintrusive.
    > So in the latest patch (still under testing, will push it out
    > soon) we have:
    > static_key_true()
    > static_key_false()
    > static_key_enabled()

    Hi Ingo,

    Yes, I think your proposal makes sense. The "_inline_" would add lots of
    typing for little clarity value. And I guess people will get used to
    these constructs.

    Acked-by: Mathieu Desnoyers <>



    Mathieu Desnoyers
    Operating System Efficiency R&D Consultant
    EfficiOS Inc.

     \ /
      Last update: 2012-02-24 16:55    [W:0.021 / U:12.020 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site