[lkml]   [2012]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs
On 02/22/2012 07:19 AM, Jason Baron wrote:
> Right, we've discussed an 'unbiased' variant a bit before, but I don't
> have a working imlementation for it yet. But I agree all current users are of
> the biased variety.
> Also, decoupling the higher level interfaces, as Ingo has suggested -
> 'very_unlikely' 'static_key', from the lower level 'jump label' naming makes
> sense. We might eventually add an 'unbias' variant. Another potential variant
> is in the 'bias' case is to move the mostly not taken branch even further out
> of line. Another possibilty is a 'switch'-like variant or multi-way jump.

Okay, at least we need something to connect the readout with the key,
otherwise there is nothing that even hints that they are part of the
same fundamental subsystem...

I don't know if key_likely() and key_unlikely() would make sense...


H. Peter Anvin, Intel Open Source Technology Center
I work for Intel. I don't speak on their behalf.

 \ /
  Last update: 2012-02-22 16:43    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean