lkml.org 
[lkml]   [2012]   [Feb]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/5] TTY: use tty_standard_install
On 02/03/2012 12:05 AM, Greg KH wrote:
> On Mon, Jan 30, 2012 at 09:14:30PM +0100, Jiri Slaby wrote:
>> Use the helper in the rest of the tty drivers. This is a simple
>> replacement.
>
> It would be, if you actually built this patch, as it is, it breaks :(

Yes, I replied to this patch that I sent you some broken bastard. Also I
attached the correct version...

>> --- a/drivers/isdn/capi/capi.c
>> +++ b/drivers/isdn/capi/capi.c
>> @@ -1015,14 +1015,11 @@ capinc_tty_install(struct tty_driver *driver, struct tty_struct *tty)
>> {
>> int idx = tty->index;
>> struct capiminor *mp = capiminor_get(idx);
>> - int ret = tty_init_termios(tty);
>> + int ret = tty_standard_install(tty);
>
> This, and, all of the other calls in this patch, should be (driver, tty)
> for the function arguments, right?
>
> That seems to fix the build for me, so I've checked it in, but please
> verify that I got it right.

It is OK.

Sorry for that.

thanks,
--
js
suse labs


\
 
 \ /
  Last update: 2012-02-03 00:25    [from the cache]
©2003-2011 Jasper Spaans