lkml.org 
[lkml]   [2012]   [Feb]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] Perf: bug fix: distinguish between rename and exec
    Em Wed, Feb 15, 2012 at 01:48:33PM +0100, Peter Zijlstra escreveu:
    > I really dislike changing generic code purely for the purpose of
    > instrumentation like this. Better to pull perf_event_comm() out of here
    > if you want to change semantics.
    >
    > Personally I couldn't care less about renames, I think they're a waste
    > of time, so I'm ok with the simple patch moving the perf_event_comm()
    > into setup_new_exec() and possibly renaming it to perf_event_exec().
    >
    > Acme, do you care about renames?

    I like your idea of keeping the semantics of PERF_RECORD_COMM and
    introducing a PERF_RECORD_EXEC, just have to think about how to handle
    that in a way that the tools detect that we have PERF_RECORD_EXEC...

    Humm, will be yet another fallback for setting an perf_event_attr bit,
    just like with .sample_id_all and .exclude_{guest,host}...

    That together with the per class errnos + __strerror() method will allow
    to move all the event creation finally to perf_evlist__open() where all
    this gets nicely hidden away from poor tools.

    We can then even have an ui__evlist_perror() method that does all the
    ui__warning calls, etc.

    So, yes, from a tooling perspective, I want to be notified of renames
    and being able to stop relying on PERF_RECORD_COMM to call
    map_groups__flush and instead do it at PERF_RECORD_EXEC seems a
    bonus.

    - Arnaldo


    \
     
     \ /
      Last update: 2012-02-15 14:51    [W:0.021 / U:32.884 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site