lkml.org 
[lkml]   [2012]   [Dec]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] mm: compare MIGRATE_ISOLATE selectively
On Fri, Dec 21, 2012 at 01:46:23PM +0100, Michal Nazarewicz wrote:
> > On Thu, Dec 20, 2012 at 04:49:44PM +0100, Michal Nazarewicz wrote:
> >> Perhaps “is_migrate_isolate” to match already existing “is_migrate_cma”?
>
> On Fri, Dec 21 2012, Minchan Kim wrote:
> > Good poking. In fact, while I made this patch, I was very tempted by renaming
> > is_migrate_cma to cma_pageblock.
> >
> > is_migrate_cma(mt)
> >
> > I don't know who start to use "mt" instead of "migratetype" but anyway, it's
> > not a good idea.
> >
> > is_migrate_cma(migratetype)
> >
> > It's very clear for me because migratetype is per pageblock, we can know the
> > function works per pageblock unit.
> >
> >> Especially as the “mt_isolated_pageblock” sound confusing to me, it
> >> implies that it works on pageblocks which it does not.
> >
> > -ENOPARSE.
> >
> > migratetype works on pageblock.
>
> migratetype is a number, which can be assigned to a pageblock. In some
> transitional cases, the migratetype associated with a page can differ
> from the migratetype associated with the pageblock the page is in. As
> such, I think it's confusing to add “pageblock” to the name of the
> function which does not read migratetype from pageblock but rather
> operates on the number it is provided.

Fair enough.

>
> > I admit mt is really dirty but I used page_alloc.c already has lots of
> > mt, SIGH.
>
> I don't really have an issue with “mt” myself, especially since the few
> times “mt” is used in page_alloc.c it is a local variable which I don't
> think needs a long descriptive name since context is all there.
>
> > How about this?
> >
> > 1. Let's change all "mt" with "migratetype" again.
> > 2. use is_migrate_isolate and is_migrate_cma for "migratetype".
> > 3. use is_migrate_isolate_page instead of page_isolated_pageblock for
> > "page".
>
> Like I've said. Personally I don't really think 1 is needed, but 2 and
> 3 look good to me.

Okay. It would be a first patch in New Year.
Thanks for the review, Michal.

>
> --
> Best regards, _ _
> .o. | Liege of Serenely Enlightened Majesty of o' \,=./ `o
> ..o | Computer Science, Michał “mina86” Nazarewicz (o o)
> ooo +----<email/xmpp: mpn@google.com>--------------ooO--(_)--Ooo--





--
Kind regards,
Minchan Kim
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2012-12-24 01:01    [W:0.044 / U:4.112 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site