lkml.org 
[lkml]   [2012]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] task_work: avoid unneeded cmpxchg() in task_work_run()
On 10/08, Lai Jiangshan wrote:
>
> We only require cmpxchg()&retry when task is exiting.
> xchg() is enough in other cases like original code in ac3d0da8.

Yes, we can probably do xchg/cmpxchg depending on NULL/work_exited.

Not sure it makes sense to complicate the code though. Is xchg()
really faster than cmpxchg?

> Also remove the inner loop

Yes, it is not really needed, only for readability.
"do while (!cmpxchg)" can be replaced with "if (!cmpxchg) continue".

> --- a/kernel/task_work.c
> +++ b/kernel/task_work.c
> @@ -56,14 +56,13 @@ void task_work_run(void)
> * work->func() can do task_work_add(), do not set
> * work_exited unless the list is empty.
> */
> - do {
> - work = ACCESS_ONCE(task->task_works);
> - head = !work && (task->flags & PF_EXITING) ?
> - &work_exited : NULL;
> - } while (cmpxchg(&task->task_works, work, head) != work);
> -
> - if (!work)
> + if (!ACCESS_ONCE(task->task_works) ||

ACCESS_ONCE() looks confusing. It is not needed with this patch.

> + !(work = xchg(&task->task_works, NULL))) {
> + if ((task->flags & PF_EXITING) &&
> + cmpxchg(&task->task_works, NULL, &work_exited))
> + continue;
> break;
> + }

I think the patch is correct.

But the code looks more complex, and the only advantage is that
non-exiting task does xchg() instead of cmpxchg(). Not sure this
worth the trouble, in this case task_work_run() will likey run
the callbacks (the caller checks ->task_works != NULL), I do not
think this can add any noticeable speedup.

But, as for correctness,
Reviewed-by: Oleg Nesterov <oleg@redhat.com>



\
 
 \ /
  Last update: 2012-10-08 15:21    [W:0.077 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site