lkml.org 
[lkml]   [2011]   [Sep]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [3.1-rc6] kmalloc(64) leak from IDE
On Sun, Sep 25, 2011 at 10:58:18AM +0200, Borislav Petkov wrote:

> On Fri, Sep 23, 2011 at 10:38:08AM -0700, Simon Kirby wrote:
> > On Fri, Sep 23, 2011 at 09:21:18AM +0200, Borislav Petkov wrote:
> >
> > > On Thu, Sep 22, 2011 at 01:23:37PM -0700, Simon Kirby wrote:
> > > > Yes, that seems to have made it stop complaining about the IDE path.
> > >
> > > Good, thanks for testing. It would be great if you left it running for
> > > a couple of days like this to see whether there aren't any other issues
> > > with the patch. I'll send it with a proper description to Dave soonish
> > > since this is a real bug.
> >
> > It has been up 22 hours now without breaking.
>
> Good.
>
> > I suppose you're worried about the old command being used after it
> > gets reused.
>
> Nah, we clear the old command before reusing it and when the request is
> done, it gets freed, AFAICT, but...

Ok, good. It's still running without any problem, and no new leaks
reported.

> > Would it help to bisect the regression to see how it used to work?
> > That would let us know how many stable kernels to patch, too.
>
> backporting it to -stable is a good point. I'll add the proper tagging
> to the patch.

Do you know in which version the issue started, then?

If not, all I have to start with is that it was fine on 2.6.36, and I can
bisect it, if that would help.

Cheers,

Simon-


\
 
 \ /
  Last update: 2011-09-26 10:07    [W:0.053 / U:6.444 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site