lkml.org 
[lkml]   [2011]   [Aug]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH ] printk: add module parameter console_suspend to control console_suspend_enabled
From
On Wed, Aug 10, 2011 at 8:57 AM, Yanmin Zhang
<yanmin_zhang@linux.intel.com> wrote:
> On Tue, 2011-08-09 at 17:59 +0800, Dave Young wrote:
>> Hi,
>>
>> On Tue, Aug 9, 2011 at 4:55 PM, Yanmin Zhang
>> <yanmin_zhang@linux.intel.com> wrote:
>> > On Tue, 2011-08-09 at 16:01 +0800, Dave Young wrote:
>> >> On Tue, Aug 9, 2011 at 11:09 AM, Yanmin Zhang
>> >> <yanmin_zhang@linux.intel.com> wrote:
>> >> > We are enabling some power features on medfield. To test suspend-2-RAM
>> >> > conveniently, we need turn on/off console_suspend_enabled frequently.
>> >> >
>> >> > Below patch adds a module parameter, so users could change it by:
>> >> > /sys/module/printk/parameters/console_suspend_enabled
>> >>
>> >> What about change name to no_console_suspend? Or it will be weird if
>> >> boot kernel with both no_console_suspend and
>> >> printk.console_suspend_enabled set.
>> > Thanks for the comments. How about changing the name to console_suspend?
>> > If changing it to no_console_suspend, we can't map the input to console_suspend_enabled
>> > directly.
>>
>> How about use module_param_cb instead of module_param_named?
> Thanks for the pointer. Indeed, we could use module_param_cb to support the
> input/output parsing. Is it too complicated to use it here? It's better
> to keep simple. The new name console_suspend is clearer than old name.

But it is a little bit confused if the param is not consistant with
no_console_suspend while use in cmdline. If we have
printk.console_suspend param, then maybe no_console_suspend can be
killed?

Anyway, I will no insist on this.

>
>>
>> >
>> > Below is the new patch.
>> >
>> > ---
>> >
>> > We are enabling some power features on medfield. To test suspend-2-RAM
>> > conveniently, we need turn on/off console_suspend_enabled frequently.
>> >
>> > Below patch adds a module parameter, so users could change it by:
>> > /sys/module/printk/parameters/console_suspend
>> >
>> > Signed-off-by: Yanmin Zhang <yanmin_zhang@linux.intel.com>
>> >
>> > ---
>> >  kernel/printk.c |    2 ++
>> >  1 files changed, 2 insertions(+), 0 deletions(-)
>> >
>> > diff --git a/kernel/printk.c b/kernel/printk.c
>> > index 37dff34..1decef6 100644
>> > --- a/kernel/printk.c
>> > +++ b/kernel/printk.c
>> > @@ -1106,6 +1106,8 @@ static int __init console_suspend_disable(char *str)
>> >        return 1;
>> >  }
>> >  __setup("no_console_suspend", console_suspend_disable);
>> > +module_param_named(console_suspend, console_suspend_enabled,
>> > +               bool, S_IRUGO | S_IWUSR);
>> >
>> >  /**
>> >  * suspend_console - suspend the console subsystem
>> > --
>
>
>



--
Regards
Yang RuiRui
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2011-08-10 03:19    [W:0.201 / U:0.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site