lkml.org 
[lkml]   [2011]   [Aug]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 06/59] Staging: hv: blkvsc: Use the newly introduced vmbus ID in the blockvsc driver
On Thu, Aug 25, 2011 at 05:52:10PM +0000, KY Srinivasan wrote:
> > No need to set the field name to nothing.
> > Hm, this could all be made even smaller with something like the
> > USB_DEVICE() macro. How about this instead:
> >
> > /* IDE guid */
> > static const struct hv_vmbus_device_id id_table[] = {
> > { VMBUS_DEVICE(0x32, 0x26, 0x41, 0x32, 0xcb, 0x86, 0xa2, 0x44,
> > 0x9b, 0x5c, 0x50, 0xd1, 0x41, 0x73, 0x54, 0xf5) },
> > { },
> > };
> >
> > That would be easier to read and understand, right? Half the number of
> > lines as well, which is always nice.
> >
> > If so, I'll go make that change here so you don't have to respin these.
>
> Looks great Greg. So you are going to add the VMBUS_DEVICE() macro?

Yes, I've now done so and pushed out the changes, which you have been
copied on, including a bug fix that I needed to make when I added the
driver_data field to the hv_vmbus_device_id structure.

I'll review the rest of the series after lunch.

thanks,

greg k-h


\
 
 \ /
  Last update: 2011-08-25 20:51    [W:0.279 / U:0.108 seconds]
©2003-2014 Jasper Spaans. Advertise on this site