lkml.org 
[lkml]   [2011]   [Jul]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    Subject[024/107] drm/radeon/kms/atom: fix duallink on some early DCE3.2 cards
    2.6.39-stable review patch.  If anyone has any objections, please let us know.

    ------------------

    From: Alex Deucher <alexdeucher@gmail.com>

    commit 8323fa6ba313ae2664420ec34d56a7fb0bbbe525 upstream.

    Certain revisions of the vbios on DCE3.2 cards have a bug
    in the transmitter control table which prevents duallink from
    being enabled properly on some cards. The action switch statement
    jumps to the wrong offset for the OUTPUT_ENABLE action. The fix
    is to use the ENABLE action rather than the OUTPUT_ENABLE action
    on the affected cards. In fixed version of the vbios, both
    actions jump to the same offset, so the change should be safe.

    Reported-and-tested-by: Dave Airlie <airlied@redhat.com>
    Signed-off-by: Alex Deucher <alexdeucher@gmail.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

    ---
    drivers/gpu/drm/radeon/radeon_encoders.c | 6 +++++-
    1 file changed, 5 insertions(+), 1 deletion(-)

    --- a/drivers/gpu/drm/radeon/radeon_encoders.c
    +++ b/drivers/gpu/drm/radeon/radeon_encoders.c
    @@ -1294,7 +1294,11 @@ radeon_atom_encoder_dpms(struct drm_enco
    if (is_dig) {
    switch (mode) {
    case DRM_MODE_DPMS_ON:
    - atombios_dig_transmitter_setup(encoder, ATOM_TRANSMITTER_ACTION_ENABLE_OUTPUT, 0, 0);
    + /* some early dce3.2 boards have a bug in their transmitter control table */
    + if ((rdev->family == CHIP_RV710) || (rdev->family == CHIP_RV730))
    + atombios_dig_transmitter_setup(encoder, ATOM_TRANSMITTER_ACTION_ENABLE, 0, 0);
    + else
    + atombios_dig_transmitter_setup(encoder, ATOM_TRANSMITTER_ACTION_ENABLE_OUTPUT, 0, 0);
    if (atombios_get_encoder_mode(encoder) == ATOM_ENCODER_MODE_DP) {
    struct drm_connector *connector = radeon_get_connector_for_encoder(encoder);




    \
     
     \ /
      Last update: 2011-07-08 07:05    [W:0.021 / U:0.720 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site