[lkml]   [2011]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 3/6] x86,64: Simplify save_regs()
On 07/06/2011 10:34 AM, Andi Kleen wrote:
> Frederic Weisbecker <> writes:
>> I really did not think about code duplication, considering
>> it's better to optimize the irq entry path.
>> What do you guys think? We can still revert the whole patchset.
> FWIW I think it should be a macro, like it was in the original code.
> Optimizing entry*.S for code size doesn't make a lot of sense.

Code size, no.

*Path* size and cache/prefetch friendliness is another matter.
The subroutine is bad on that account, too, so yes, this really seems
like a losing proposition.

I'm not too fond of the gajillion obtuse macros we have, but subroutines
doesn't make it really any better.


 \ /
  Last update: 2011-07-06 20:23    [W:0.115 / U:0.604 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site