[lkml]   [2011]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: IP forwarding regression since 3.0-rc6
Le vendredi 29 juillet 2011 à 09:15 +0200, Stephan Seitz a écrit :
> On Thu, Jul 28, 2011 at 03:46:33PM +0200, Maciej Rutecki wrote:
> >I created a Bugzilla entry at
> >
> >for your bug report, please add your address to the CC list in there, thanks!
> Thank you for creating a bug report for me. I have added my address to
> the CC list.

CC netdev

I suspect your configuration is too complex, and maybe the only way to
track the bug is to perform a git bisection.

Your initial message was :

Since 3.0-rc6 I see that my Linux router is losing packets. I can see
them tracing the internal interface, but I don’t see them on the external
interface. I can reproduce the problem while using tin with At the startup when tin checks every newsgroup from
the server, many packets are suddenly not routed anymore but are dropped,
so tin hangs until it quits with a NNTP error.
All kernels until 3.0-rc5 are working.

- 2x Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit
Ethernet controller

- Debian Testing, 64bit, with Xen 4.1.0

Dom0 (Debian Testing, 64bit) is my working system. The two NICs have each
their own bridge interface. One bridge interface (A) has an internal IP
address (IPv4 and IPv6) of my internal network. The other bridge (B)
doesn’t have a IP address in Dom0. The DomU is connected to the two
DomU (Debian Testing, 64bit) is my iptables firewall system with Bind,
Squid, and other services. The interface connected to bridge A has an
internal IP addresses (gateway for my internal network). The interface
connected to bridge B is used for PPPoE (the NIC is directly connected to
my DSL modem).

Dom0 has had all kernel versions from 3.0-rcX and is running 3.0 at the
DomU has had the same kernel versions but is running 3.0-rc5 at the
moment because of the network problems in newer kernels.

Long problem description:
From Dom0 I use tin to read different newsserver. One of them is The first time after DomU switched kernel to -rc6
I started tin (connecting to the mentioned news server) and tin hung
while reading groups from the newsrc and stopped with a NNTP connection
Since the problem didn’t vanish, I wrote a mail to the support team of
the news server. They told me that I was the only one with a connection
problem and asked me to try the connection from another client. I tried
it from my vServer, and it worked. So the problem had to be in my setup.

I traced in Dom0 (bridge A), DomU (bridge A) und DomU (ppp0) and noticed
that all packets generated in Dom0 were visible in DomU bridge A. But not
all of the packets were visisble at the ppp0 interface. So my DomU was
dropping packets and the connection between tin in Dom0 and the news
server failed.

So I tried older kernels and noticed that 3.0-rc5 in DomU was working,
but rc6 and newer were not. The kernel configuration was the same for all
3.0 kernels.

Since I don’t know which maintainer I should contact with my problem,
I’ll write directly to lkml.

Thanks for your help.

Shade and sweet water!


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2011-07-29 09:35    [W:0.112 / U:1.268 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site