lkml.org 
[lkml]   [2011]   [Jul]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ac97: quiet make W=1 noise by initializing all fields of snd_ac97_codec_id_vendors and snd_ac97_codec_ids.
At Sun, 24 Jul 2011 11:40:56 +0200,
Lionel Debroux wrote:
>
> make W=1 bitterly complains about missing initializations in
> snd_ac97_codec_id_vendors and snd_ac97_codec_ids.
> Initialize the last field, to make the output of make W=1 more readable.
>
> Patch against current Linus tree.

If we change the whole table entries, it'd be better to use C99 style
init, e.g.

#define _CODEC(_id, _mask, _name) \
.id = _id, .mask = _mask, .name = _name

static const struct ac97_codec_id snd_ac97_codec_id_vendors[] = {
{ _CODEC(0x41445300, 0xffffff00, "Analog Devices"),},
...

static const struct ac97_codec_id snd_ac97_codec_ids[] = {
{ _CODEC(0x41445303, 0xffffffff, "AD1819"), .patch = patch_ad1819 },
...
{ _CODEC(0x53494c20, 0xffffffe0, "Si3036,8"), .patch = mpatch_si3036, \
.mpatch = mpatch_si3036, .flags = AC97_MODEM_PATCH },
...


thanks,

Takashi


\
 
 \ /
  Last update: 2011-07-25 12:57    [W:1.980 / U:0.692 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site