lkml.org 
[lkml]   [2011]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [1/4] rcu: Detect uses of rcu read side in extended quiescent states
On Tue, Jun 07, 2011 at 11:34:14AM -0700, Paul E. McKenney wrote:
> On Tue, Jun 07, 2011 at 02:58:13PM +0200, Frederic Weisbecker wrote:
> > On Mon, Jun 06, 2011 at 09:40:05PM -0700, Paul E. McKenney wrote:>
> > > The bit I am missing is how to distinguish between spinlocks (where
> > > sleeping is illegal) and mutexes (where sleeping is perfectly fine).
> > > We could teach lockdep the difference, I suppose, but it is not clear
> > > to me that it is worth it.
> >
> > Ah, in fact it doesn't pass through any lockdep check.
> >
> > It's only a function called might_sleep() that is placed in functions
> > that can sleep. And inside might_sleep() it checks whether it is in a preemptible
> > area. So it's actually locking-agnostic, it only relies on the preempt_count
> > and some more for the preempt rcu cases.
> >
> > I think it is called CONFIG_DEBUG_SPINLOCK_SLEEP because it was first used
> > for spinlock debugging purposes. But then it has a broader use now: sleep
> > inside preemptible section, sleep inside interrupts, sleep inside rcu.
>
> But the __might_sleep() function can only differentiate between
> spinlocks and sleeplocks if CONFIG_PREEMPT=y.

It doesn't differentiate between locks but checks on the lowest level
by looking at the preempt count. But yeah it only works if CONFIG_PREEMPT,
which is why I proposed to inc/dec the preempt count also when we have
that DEBUG_SPINLOCK_SLEEP.

>
> > It certainly deserves a rename, like CONFIG_DEBUG_ILLEGAL_SLEEP.
>
> Hmmm... It already checks for sleeping in the middle of a
> preempt_disable() as well as in a spinlock critical section.
> So the need for a rename is independent of any RCU checking.

Sure, rcu just adds itself to the pile of users of might_sleep(), thus
it would be a nice cleanup to rename the option to something more
generic. But that rename is not necessary to improve RCU checking.

>
> > > In contrast, with RCU, this is straightforward -- check for rcu_sched
> > > and rcu_bh, but not SRCU.
>
> Actually it makes sense to keep the checks in rcu_note_context_switch(),
> as there are places that call schedule() directly without a might_sleep().
> Perhaps having checks in both places is the correct approach?

In this case it makes more sense to add your checks in schedule_debug(),
so that we don't wait for a context switch to detect the bug.


\
 
 \ /
  Last update: 2011-06-07 20:51    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site