[lkml]   [2011]   [Jun]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: immediately reboots/resets on EFI system
    On 06/03/2011 04:46 PM, Matthew Garrett wrote:
    > On Fri, Jun 03, 2011 at 04:26:27PM +0200, Jim Bos wrote:
    >> On 06/03/2011 03:33 PM, Matthew Garrett wrote:
    >>> ? You've got 143 boot services/code regions, which is more than I'd
    >>> tested against, so I'm unsure whether we're overflowing something here.
    >> That's seems to be the only EFI patch in and I effectively
    >> removed by =not= applying (skipping) the parts of the patch to
    >> above 3 files.
    >> So yes removing "x86, efi: Retain boot service code until after
    >> switching to virtual mode" indeed fixes the problem for me.
    > Ok, thanks. I'll look into that. Might be best to drop it from stable
    > for the moment until I've made sure it works on machines with excessive
    > maps.


    Another datapoint, just tried a 3.0.0-rc1 kernel, good news is that it
    boots. Maybe the "x86, efi: Merge contiguous memory regions of the same
    type" helps with these large number of maps?

    However, there seems to be something else wrong as I get several "BUG:
    Bad page state in process swapper pfn:00000" which have efi functions
    on the stack, see dmesg output.

    [unhandled content-type:application/gzip]
     \ /
      Last update: 2011-06-05 12:57    [W:0.042 / U:71.572 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site