[lkml]   [2011]   [Jun]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] fix bogus use of rc = alloc_chrdev_region()
On Tue, Jun 14, 2011 at 12:17 PM, Arnd Bergmann <> wrote:
> On Tuesday 14 June 2011 18:23:50 Grant Likely wrote:
>> On Tue, Jun 14, 2011 at 8:07 AM, Arnd Bergmann <> wrote:
>> > On the topic of drivers/char/{nsc_gpio,pc8736x_gpio,scx200_gpio}, I wonder
>> > if we should move them to drivers/gpio/nsc_gpio despite the fact that they
>> > use a different (older) interface than all the other gpio drivers.
>> I have no problem with moving them into drivers/gpio.  When you do,
>> please rename then drivers/gpio/gpio-*.c
> Ok. Should they be in a subdirectory drivers/gpio/nsc_gpio/gpio_* for the
> nonstandard API or do you prefer them to live amongst the regular ones?

converting these to gpiolib has been on my list for a while, but
pretty far down.
Moving them is an easy 1st step.
Once theyre converted, I guess they belong with the others,
but its easy to move them again when the convert is done.
preference ?

>        Arnd
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2011-06-14 20:27    [W:0.547 / U:1.344 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site