lkml.org 
[lkml]   [2011]   [Jun]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [alsa-devel] Headphone output doesn't work with 3.0.0-rc* anymore
    At Fri, 10 Jun 2011 14:42:32 +0200,
    Michal Hocko wrote:
    >
    > On Fri 10-06-11 12:08:03, Takashi Iwai wrote:
    > > At Fri, 10 Jun 2011 11:30:19 +0200,
    > > Michal Hocko wrote:
    > > >
    > > > On Fri 10-06-11 11:18:51, Takashi Iwai wrote:
    > > > > At Fri, 10 Jun 2011 10:51:17 +0200,
    > > > > Michal Hocko wrote:
    > > > > >
    > > > > > On Fri 10-06-11 10:14:13, Takashi Iwai wrote:
    > > > > > > At Fri, 10 Jun 2011 09:56:40 +0200,
    > > > > > > Michal Hocko wrote:
    > > > > > > >
    > > > > > > > On Fri 10-06-11 08:53:01, Takashi Iwai wrote:
    > > > > > > > > At Thu, 9 Jun 2011 13:14:01 +0200,
    > > > [...]
    > > > > > > > OK, I git checkout v2.6.39 -- sound/pci/*.[ch] (see the patch bellow for
    > > > > > > > reference). I have kept the earlier patch.
    > > > > > >
    > > > > > > Gah, sorry, a wrong path. It must be sound/pci/hda/*.[ch].
    > > > > > > Also, please remove my previous patch. It's irrelevant with 2.6.39
    > > > > > > although it should be harmless.
    > > > > >
    > > > > > OK, I have reverted the whole hda directory to 2.6.39 which means AFAIU
    > > > > > that the driver is at the same state as it was in that kernel. And the
    > > > > > sound really works. Both outputs are active whem they should be.
    > > > >
    > > > > Thanks, it's really good to know that we have a good working-base.
    > > > >
    > > > > Now, can you switch back to 3.0rc2 with my fix patch and retest?
    > > >
    > > > Sorry, I am confused now. How this would be different from the previous
    > > > testing where I had that patch applied on top of rc2?
    > >
    > > Never mind, I found the possible spot.
    > > Could you try the patch below in addition? There was one missing
    > > initialization in the transition.
    >
    > I have applied this patch on top of clean rc2.

    And apply my previous patch, too. There are two fixes.


    thanks,

    Takashi


    \
     
     \ /
      Last update: 2011-06-10 14:45    [W:0.022 / U:0.656 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site