lkml.org 
[lkml]   [2011]   [May]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [tip:x86/urgent] x86, asm: Clean up desc.h a bit

* H. Peter Anvin <hpa@zytor.com> wrote:

> On 05/27/2011 01:39 AM, tip-bot for Ingo Molnar wrote:
> > Commit-ID: 9a3865b185e77d1a4ca2d8356e37c19b78168961
> > Gitweb: http://git.kernel.org/tip/9a3865b185e77d1a4ca2d8356e37c19b78168961
> > Author: Ingo Molnar <mingo@elte.hu>
> > AuthorDate: Fri, 27 May 2011 09:29:32 +0200
> > Committer: Ingo Molnar <mingo@elte.hu>
> > CommitDate: Fri, 27 May 2011 09:30:50 +0200
> >
> > x86, asm: Clean up desc.h a bit
> >
> > I have looked at this file and found it rather ugly - improve
> > readability a bit. No change in functionality.
> >
>
> It sure is, but let me also register for the record that I hate the
> bloody bitfield. A lot of what the bitfield does is completely
> pointless (breaking down the type field, which really is nothing other
> than a magic constant as far as the kernel is anyway) and generates
> insanely bad code.
>
> I honestly think if we used macros like GDT_ENTRY() and perhaps a few
> variants we would make the code simpler.

Yeah. I really didnt want to modify functionality in this patch, just
wanted my eyes to not bleed. Using macros there would probably
generate better code as well, right?

Thanks,

Ingo


\
 
 \ /
  Last update: 2011-05-27 19:15    [from the cache]
©2003-2011 Jasper Spaans