lkml.org 
[lkml]   [2011]   [Feb]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectlinux-next: build warnings after merge of the i2c tree
Hi Jean,

After merging the tip tree, today's linux-next build (powerpc
ppc64_defconfig) produced these warnings:

drivers/i2c/i2c-core.c: In function 'i2c_do_add_adapter':
drivers/i2c/i2c-core.c:799: warning: 'attach_adapter' is deprecated (declared at include/linux/i2c.h:149)
drivers/i2c/i2c-core.c:804: warning: 'attach_adapter' is deprecated (declared at include/linux/i2c.h:149)
drivers/i2c/i2c-core.c: In function 'i2c_do_del_adapter':
drivers/i2c/i2c-core.c:985: warning: 'detach_adapter' is deprecated (declared at include/linux/i2c.h:150)
drivers/i2c/i2c-core.c:988: warning: 'detach_adapter' is deprecated (declared at include/linux/i2c.h:150)

Introduced by commit 95529c656b97b08c7a92504f98650a229f03ae04 ("i2c:
Deprecate i2c_driver.attach_adapter and .detach_adapter"). We normally
fix up as many uses of an interface as possible before deprecating it ...

--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
http://www.canb.auug.org.au/~sfr/
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2011-02-21 05:37    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site