lkml.org 
[lkml]   [2011]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [rfc 3/3] prctl: Add PR_SET_MM codes to tune up mm_struct entires
    On Wed, Dec 07, 2011 at 02:43:55PM -0800, Andrew Morton wrote:
    > On Wed, 7 Dec 2011 16:27:18 +0400
    > Cyrill Gorcunov <gorcunov@gmail.com> wrote:
    >
    > > At process of task restoration we need a way to tune up
    > > a few members of mm_struct structure such as start_code,
    > > end_code, start_data, end_data, start_stack, start_brk, brk.
    >
    > I don't really know what "tune up" means in this context. Can we
    > please be more specific and detailed here? It appears that the patch
    > permits userspace to directly modify these fields.
    >

    ok

    >
    > The prctl(2) manpage will need to be updated. Please Cc Michael on all
    > such changes.
    >

    you mean -- Michael Kerrisk, mtk AT man7.org, right?

    ...
    > > +
    > > + mm = get_task_mm(current);
    >
    > Is it necessaary to run the expensive get_task_mm() for `current'?
    > `current' is known to be running and you have control of it here -
    > nobody will be taking our mm away. Simply use current->mm? The
    > function actually uses current->mm later on in several places.

    hmm, indeed, i'll update, thanks!

    >
    > > + if (!mm)
    > > + return -ENOENT;
    > > +
    > > + down_read(&mm->mmap_sem);
    > > + vma = find_vma(mm, addr);
    > > +
    > > + if (opt != PR_SET_MM_START_BRK &&
    > > + opt != PR_SET_MM_BRK) {
    >
    > 80 columns, not 40 :)
    >
    > > + /* It must be existing VMA */
    > > + if (!vma || vma->vm_start > addr)
    > > + goto out;
    > > + }
    > > +
    > > + error = -EINVAL;
    > > + switch (opt) {
    > > + case PR_SET_MM_START_CODE:
    > > + case PR_SET_MM_END_CODE:
    > > +
    >
    > You're adding unneeded and unconventional newlines after the `case'
    > statements.
    >

    no, I added them by a purpose -- it's a way easier to read these
    assignments, but fine -- I'll drop this nits.

    >
    > This is starting to add a non-trivial amount of code. Perhaps we need
    > to introduce a Kconfig variable to control such things as this, to
    > prevent bloating up kernels which aren't require to support c/r?
    >

    Dunno, Andrew. Actually I agreed that these snippets are mostly
    needed for c/r only, but the initial idea over all changes was
    to add levers into kernel which might be helpful not only
    for c/r but for someone else as well.

    Cyrill


    \
     
     \ /
      Last update: 2011-12-08 08:09    [W:2.709 / U:0.096 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site