lkml.org 
[lkml]   [2011]   [Dec]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH RFC V3 2/4] kvm hypervisor : Add a hypercall to KVM hypervisor to support pv-ticketlocks
    On Wed, Dec 07, 2011 at 05:24:59PM +0530, Raghavendra K T wrote:
    > On 12/07/2011 04:18 PM, Marcelo Tosatti wrote:
    > >On Wed, Nov 30, 2011 at 02:29:59PM +0530, Raghavendra K T wrote:
    > >>
    > >>+/*
    > >>+ * kvm_pv_kick_cpu_op: Kick a vcpu.
    > >>+ *
    > >>+ * @cpu - vcpu to be kicked.
    > >>+ */
    > >>+static void kvm_pv_kick_cpu_op(struct kvm *kvm, int cpu)
    > >>+{
    > >>+ struct kvm_vcpu *vcpu = kvm_get_vcpu(kvm, cpu);
    > >>+ struct kvm_mp_state mp_state;
    > >>+
    > >>+ mp_state.mp_state = KVM_MP_STATE_RUNNABLE;
    > >
    > >Since vcpu->mp_state is not protected by a lock, this is potentially racy. For example:
    > >
    > >CPU0 CPU1
    > >kvm_pv_kick_cpu_op running vcpuN
    > >vcpuN->mp_state = KVM_MP_STATE_RUNNABLE;
    > > kvm_emulate_halt
    > > vcpuN->mp_state = KVM_MP_STATE_HALTED
    > >
    > >Is it harmless to lose a kick?
    > >
    >
    > Yes you are right. It was potentially racy and it was harmful too!.
    > I had observed that it was stalling the CPU before I introduced
    > kicked flag.
    >
    > But now,
    >
    > vcpu->kicked = 1 ==> kvm_make_request(KVM_REQ_UNHALT, vcpu); ==>

    Ok, please use a more descriptive name, such as "pvlock_kicked" or
    something.

    >
    > __vcpu_run() ==> kvm_check_request(KVM_REQ_UNHALT, vcpu) ==>
    >
    > vcpuN->mp_state = KVM_MP_STATE_RUNNABLE; so eventually we will end up
    > in RUNNABLE.
    >
    > Also Avi pointed that, logically kvm_arch_vcpu_ioctl_set_mpstate should
    > be called only in vcpu thread, so after further debugging, I noticed
    > that, setting vcpuN->mp_state = KVM_MP_STATE_RUNNABLE; is not
    > necessary.
    > I 'll remove that in the next patch. Thanks for pointing.

    In fact you don't need kvm_arch_vcpu_ioctl_set_mpstate either, only the
    new "kicked" flag.

    >
    >
    >


    \
     
     \ /
      Last update: 2011-12-07 13:37    [W:3.183 / U:0.908 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site