lkml.org 
[lkml]   [2011]   [Dec]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRE: [RFC PATCH v2 1/4] dt: add of_get_child_number helper function
    Date
    > -----Original Message-----
    > From: glikely@secretlab.ca [mailto:glikely@secretlab.ca] On Behalf Of
    > Grant Likely
    > Sent: Thursday, December 15, 2011 5:41 AM
    > To: Rob Herring
    > Cc: Dong Aisheng-B29396; linux-kernel@vger.kernel.org; linux-arm-
    > kernel@lists.infradead.org; linus.walleij@stericsson.com;
    > s.hauer@pengutronix.de; Guo Shawn-R65073; kernel@pengutronix.de
    > Subject: Re: [RFC PATCH v2 1/4] dt: add of_get_child_number helper
    > function
    > Importance: High
    >
    > On Wed, Dec 14, 2011 at 11:04 AM, Rob Herring <robherring2@gmail.com>
    > wrote:
    > > Dong,
    > >
    > > On 12/14/2011 10:03 AM, Dong Aisheng wrote:
    > >> From: Dong Aisheng <dong.aisheng@linaro.org>
    > >>
    > >> Currently most code to get child number in kernel are almost same,
    > >> add a helper to implement this function for dt to use.
    > >>
    > >> Signed-off-by: Dong Aisheng <dong.aisheng@linaro.org>
    > >> Cc: Grant Likely <grant.likely@secretlab.ca>
    > >> Cc: Rob Herring <rob.herring@calxeda.com>
    > >> ---
    > >>  include/linux/of.h |   17 +++++++++++++++++
    > >>  1 files changed, 17 insertions(+), 0 deletions(-)
    > >>
    > >> diff --git a/include/linux/of.h b/include/linux/of.h index
    > >> 4948552..09d53dc 100644
    > >> --- a/include/linux/of.h
    > >> +++ b/include/linux/of.h
    > >> @@ -189,6 +189,18 @@ extern struct device_node
    > >> *of_get_next_child(const struct device_node *node,
    > >>       for (child = of_get_next_child(parent, NULL); child != NULL; \
    > >>            child = of_get_next_child(parent, child))
    > >>
    > >> +static inline int of_get_child_number(struct device_node *np)
    > >
    > > I would call this of_get_child_count instead.
    >
    > I agree.
    >
    Yes, will change to that name.
    Thanks for the suggestion.

    Regards
    Dong Aisheng


    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2011-12-15 06:53    [W:0.025 / U:0.816 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site