lkml.org 
[lkml]   [2011]   [Nov]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 05/17] freezer: rename thaw_process() to __thaw_task() and simplify the implementation
Hello,

On Sun, Nov 06, 2011 at 05:34:27PM +0530, Srivatsa S. Bhat wrote:
> On 11/01/2011 12:35 AM, Tejun Heo wrote:
> > * task_lock() is needed to prevent the race with refrigerator() which may
> ^^^^^^
> __refrigerator()?

I don't think this really matters. Maybe just drop () from the
comment?

> Rebasing to latest kernel, we need to do the conversion in mm/oom_kill.c as well,
> (and consequently add __thaw_task() empty function under !CONFIG_FREEZER, in
> include/linux/freezer.h)

Yes, for merging, we should do that, but for longer term, as we can
modify freezing condition with relative ease now, I think we should
make tasks being killed ignore freezer instead of relying on
explicitly calling __thaw_task() which is inherently racy.

Thank you.

--
tejun


\
 
 \ /
  Last update: 2011-11-06 17:53    [W:0.063 / U:7.456 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site