lkml.org 
[lkml]   [2011]   [Nov]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 02/10] threadgroup: rename signal->threadgroup_fork_lock to ->group_rwsem
On Fri, Nov 04, 2011 at 05:40:32PM +0900, KAMEZAWA Hiroyuki wrote:
> On Tue, 1 Nov 2011 16:46:25 -0700
> Tejun Heo <tj@kernel.org> wrote:
>
> > Make the following renames to prepare for extension of threadgroup
> > locking.
> >
> > * s/signal->threadgroup_fork_lock/signal->group_rwsem/
> > * s/threadgroup_fork_read_lock()/threadgroup_change_begin()/
> > * s/threadgroup_fork_read_unlock()/threadgroup_change_done()/
>
> I personally like begin <-> end to see relationship.

Hmmm... yeah, I like that better too. Renaming.

Thanks.

--
tejun


\
 
 \ /
  Last update: 2011-11-04 16:19    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site