lkml.org 
[lkml]   [2011]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 10/28] fcntl: Use current logging style
Date
Add and use pr_fmt and pr_<level>.
Output message now prefixed with "fcntl: " and
%s:, __func__, (kill_fasync_rcu) now used as well.

Signed-off-by: Joe Perches <joe@perches.com>
---
fs/fcntl.c | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/fs/fcntl.c b/fs/fcntl.c
index 22764c7..5d16b1d 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -4,6 +4,8 @@
* Copyright (C) 1991, 1992 Linus Torvalds
*/

+#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
+
#include <linux/syscalls.h>
#include <linux/init.h>
#include <linux/mm.h>
@@ -797,8 +799,8 @@ static void kill_fasync_rcu(struct fasync_struct *fa, int sig, int band)
unsigned long flags;

if (fa->magic != FASYNC_MAGIC) {
- printk(KERN_ERR "kill_fasync: bad magic number in "
- "fasync_struct!\n");
+ pr_err("%s: bad magic number in fasync_struct!\n",
+ __func__);
return;
}
spin_lock_irqsave(&fa->fa_lock, flags);
--
1.7.6.405.gc1be0


\
 
 \ /
  Last update: 2011-11-30 03:19    [W:0.148 / U:0.276 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site