[lkml]   [2011]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH v3 3/4] mm-tracepoint: rename page-free events
    On Fri, Nov 11, 2011 at 10:40 PM, Konstantin Khlebnikov
    <> wrote:
    > Rename mm_page_free_direct into mm_page_free
    > and mm_pagevec_free into mm_page_free_batched
    > Since v2.6.33-5426-gc475dab kernel trigger mm_page_free_direct for all freed pages,
    > not only for directly freed. So, let's name it properly.
    > For pages freed via page-list we also trigger mm_page_free_batched event.
    > Signed-off-by: Konstantin Khlebnikov <>
    Reviewed-by: Minchan Kim <>

    1+ for clear naming but I am not quite sure event name change is
    always OK for compatibility of old perf.
    At least, we will need to Cced Ingo, I think.

    Kind regards,
    Minchan Kim

     \ /
      Last update: 2011-11-12 00:39    [W:0.019 / U:33.332 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site