lkml.org 
[lkml]   [2011]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/6] udf: Change some KERN_<level>s and logging neatening
Date
I reviewed your patch and think it's too large
for others to review because it combines multiple
things into a single patch.

I think that adding struct super_block * to udb_debug
isn't necessary or particularly useful.

Here are the changes to your original patch that I made:

Separate a single large patch into reviewable chunks.
Don't convert every message type to udf_<foo>.

Joe Perches (6):
udf: Promote some debugging messages to udf_error
udf: Rename udf_error to udf_err
udf: Rename udf_warn to udf_warn
udf: Convert printks to pr_<level>
udf: Neaten logging output, use vsprintf extension %pV
udf: Neaten udf_debug uses

fs/udf/balloc.c | 14 ++--
fs/udf/directory.c | 8 +-
fs/udf/inode.c | 36 ++++-----
fs/udf/lowlevel.c | 2 +-
fs/udf/misc.c | 24 ++++---
fs/udf/namei.c | 5 +-
fs/udf/partition.c | 11 +--
fs/udf/super.c | 214 +++++++++++++++++++++++-----------------------------
fs/udf/truncate.c | 21 ++---
fs/udf/udfdecl.h | 35 ++++++---
fs/udf/udftime.c | 3 +-
fs/udf/unicode.c | 6 +-
12 files changed, 178 insertions(+), 201 deletions(-)

--
1.7.6.405.gc1be0



\
 
 \ /
  Last update: 2011-10-10 10:11    [W:0.296 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site