lkml.org 
[lkml]   [2011]   [Jan]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [tip:x86/numa] x86: Unify cpu/apicid <-> NUMA node mapping between 32 and 64bit
Hello, Yinghai.

On Fri, Jan 28, 2011 at 12:33:00PM -0800, Yinghai Lu wrote:
> > +#ifdef CONFIG_NUMA
> > +extern int __cpuinit numa_cpu_node(int apicid);
>
> cpu or apicid?

Should have been @cpu. Will send a patch to update it.

> > +int __cpuinit numa_cpu_node(int cpu)
> > +{
> > + int apicid = early_per_cpu(x86_cpu_to_apicid, cpu);
> > +
> > + if (apicid != BAD_APICID)
> > + return __apicid_to_node[apicid];
> > + return NUMA_NO_NODE;
> > +}
>
> it should be changed to cpu_to_node_via_apicid(), it could return
> not onlined node, aka node without memory.
>
> So don't mess it up with cpu_to_node()

Hmmm... are you saying that the name is too confusing with
cpu_to_node() and should be renamed to cpu_to_node_via_apicid()? In
that case, I agree but wish the name were something which represents
what it does as _via_apicid postfix doesn't really tell much. Any
better idea?

Thanks.

--
tejun


\
 
 \ /
  Last update: 2011-01-31 16:55    [W:0.075 / U:0.240 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site