lkml.org 
[lkml]   [2011]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] memcg: remove charge variable in unmap_and_move
On Tue, 11 Jan 2011 17:51:12 +0900
Minchan Kim <minchan.kim@gmail.com> wrote:

> memcg charge/uncharge could be handled by mem_cgroup_[prepare/end]
> migration itself so charge local variable in unmap_and_move lost the role
> since we introduced 01b1ae63c2.
>
> In addition, the variable name is not good like below.
>
> int unmap_and_move()
> {
> charge = mem_cgroup_prepare_migration(xxx);
> ..
> BUG_ON(charge); <-- BUG if it is charged?
> ..
> uncharge:
> if (!charge) <-- why do we have to uncharge !charge?
> mem_group_end_migration(xxx);
> ..
> }
>
> So let's remove unnecessary and confusing variable.
>
> Suggested-by: Daisuke Nishimura <nishimura@mxp.nes.nec.co.jp>
> Cc: Balbir Singh <balbir@linux.vnet.ibm.com>
> Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
> Signed-off-by: Minchan Kim <minchan.kim@gmail.com>

Acked-by: Daisuke Nishimura <nishimura@mxp.nes.nec.co.jp>


\
 
 \ /
  Last update: 2011-01-12 01:51    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site