lkml.org 
[lkml]   [2010]   [Sep]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    SubjectRe: [PATCH v2] AT91: Add flexibity board support
    From
    Please see my comments below...

    On Tue, Sep 14, 2010 at 12:53 AM, Ryan Mallon <ryan@bluewatersys.com> wrote:
    > On 09/13/2010 10:18 PM, Maxim Osipov wrote:
    >
    >> +static void __init flexibity_board_init(void)
    >> +{
    >> +     /* Serial */
    >> +     at91_add_device_serial();
    >> +     /* USB Host */
    >> +     at91_add_device_usbh(&flexibity_usbh_data);
    >> +     /* USB Device */
    >> +     at91_add_device_udc(&flexibity_udc_data);
    >> +     /* SPI */
    >> +     at91_add_device_spi(flexibity_spi_devices,
    >> +             ARRAY_SIZE(flexibity_spi_devices));
    >> +     /* MMC */
    >> +     at91_add_device_mmc(0, &flexibity_mmc_data);
    >> +     /* LEDs */
    >> +     at91_gpio_leds(flexibity_leds, ARRAY_SIZE(flexibity_leds));
    >
    > Can we drop all the comments inside this function please. They don't add
    > any information and they make it harder to read the actual code.
    >

    Ryan, thank you for the review. However I would like to keep these
    comments - for some devices, like UDC - it really provides
    clarification. Reading the code is not a problem with proper
    highlighting scheme.

    Kind regards,
    Maxim
    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2010-09-14 07:59    [W:5.567 / U:0.008 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site