lkml.org 
[lkml]   [2010]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[RFC PATCH 0/5] Bump gcc minimum version to 3.4, 4.1 for x86
Date
This patchset bumps the minimum supported gcc version to 3.4 for the
general kernel, and to 4.1 for x86.

We have had a rash of bug reports related to these really old
compilers and their associated binutils version lately, and it is
clear that the support burden of these older compilers is getting to
be excessive. If you really want to build a kernel on a system that
old you can build or obtain an updated gcc/binutils as well.

Documentation/Changes | 2 +-
arch/x86/include/asm/bitops.h | 7 -------
arch/x86/include/asm/cpufeature.h | 7 -------
arch/x86/include/asm/string_32.h | 21 ---------------------
arch/x86/kernel/Makefile | 3 ++-
arch/x86/kernel/compiler.c | 5 +++++
include/linux/compiler-gcc3.h | 15 +--------------
7 files changed, 9 insertions(+), 51 deletions(-)


\
 
 \ /
  Last update: 2010-09-13 22:17    [W:0.093 / U:38.192 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site