lkml.org 
[lkml]   [2010]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: mmotm 2010-07-27 - hda-intel audio fails to initialize
    At Wed, 28 Jul 2010 18:23:07 -0400,
    Valdis.Kletnieks@vt.edu wrote:
    >
    > On Tue, 27 Jul 2010 14:56:50 PDT, akpm@linux-foundation.org said:
    > > The mm-of-the-moment snapshot 2010-07-27-14-56 has been uploaded to
    > >
    > > http://userweb.kernel.org/~akpm/mmotm/
    >
    > Dell Latitude E6500. Soundcard has gone astray, it appears.
    >
    > >From 2.6.35-rc3-mmotm0719 dmesg:
    >
    > [ 3.372928] usbcore: registered new interface driver usbhid
    > [ 3.372931] usbhid: USB HID core driver
    > [ 3.395281] input: Dell WMI hotkeys as /devices/virtual/input/input5
    > [ 3.396477] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
    > [ 3.433604] input: HDA Intel Mic at Sep Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
    > [ 3.433922] input: HDA Intel Mic at Ext Right Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
    > [ 3.434402] input: HDA Intel Line Out at Sep Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
    > [ 3.434668] input: HDA Intel HP Out at Ext Right Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
    > [ 3.435552] ALSA device list:
    > [ 3.435554] #0: HDA Intel at 0xf6fdc000 irq 48
    > [ 3.435588] Netfilter messages via NETLINK v0.30.
    > [ 3.435608] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
    >
    > >From 2.6.35-rc6-mmotm0727:
    >
    > [ 3.065797] usbcore: registered new interface driver usbhid
    > [ 3.065800] usbhid: USB HID core driver
    > [ 3.085379] input: Dell WMI hotkeys as /devices/virtual/input/input5
    > [ 3.086706] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
    > [ 3.086788] HDA Intel 0000:00:1b.0: irq 48 for MSI/MSI-X
    > [ 3.086841] HDA Intel 0000:00:1b.0: setting latency timer to 64
    > [ 3.095165] ALSA sound/pci/hda/hda_intel.c:1450: no codecs initialized
    > [ 3.095492] HDA Intel 0000:00:1b.0: PCI INT A disabled
    > [ 3.095640] ALSA device list:
    > [ 3.095642] No soundcards found.
    > [ 3.095676] Netfilter messages via NETLINK v0.30.
    >
    > Am I hitting a known issue? If not, what other info would help?

    This was already fixed, but in the same date (July 27) as mmotm was
    created. The commit is:

    cd7643bfb772dc7103ed6fc8dda6b233a8e14178
    Author: Jaroslav Kysela <perex@perex.cz>
    ALSA: hda-intel - fix function_id rework (add missing bitmask)


    Takashi


    \
     
     \ /
      Last update: 2010-07-29 07:41    [W:0.021 / U:61.656 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site