[lkml]   [2010]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: kmemleak, cpu usage jump out of nowhere

    > On Wed, Jul 14, 2010 at 9:12 AM, Zeno Davatz <> wrote:
    > > I got a new Intel core-8 i7 processor.

    > > I am on kernel uname -a

    > > Linux zenogentoo 2.6.35-rc5 #97 SMP Tue Jul 13 16:13:25 CEST 2010 i686
    > > Intel(R) Core(TM) i7 CPU 960 @ 3.20GHz GenuineIntel GNU/Linux

    > > Sometimes in the middle of nowhere all of a sudden all of my 8-cores
    > > are at 100% CPU usage and my machine really lags and hangs and is not
    > > useable anymore. Some random process just grabs a bunch CPUs according
    > > to htop.

    * Pekka Enberg <> [2010-07-14 11:05]:
    > Why did you enable CONFIG_DEBUG_KMEMLEAK? Memory leak scanning is
    > likely the source of these pauses.

    I am seeing the same problem with a Core i7 920 and 2.6.35-rc5, and I do
    not have CONFIG_DEBUG_KMEMLEAK enabled, so I think this is not related.

    I do not see anything special in the logs, just the load becoming mad
    and almost preventing ssh access. I've been seeing that since the first
    2.6.35 rc I tested (-rc2 or -rc3, I don't remember) and I did not have
    time to report it before but I was surprised nobody else did. No problem
    with 2.6.34 and


     \ /
      Last update: 2010-07-14 10:43    [W:0.048 / U:5.732 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site