lkml.org 
[lkml]   [2010]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: 2.6.35-rc3: System unresponsive under load
From
On Sat, Jun 26, 2010 at 5:47 PM, Manfred Spraul
<manfred@colorfullife.com> wrote:
> Hi Luca,
>
> On 06/26/2010 02:52 PM, Luca Tettamanti wrote:
>>
>> They don't seem really hung as before, I see two different behaviours:
>> * Near the end of the run ab is frozen for a few seconds, but in the
>> end all requests are processed; however I see a few "length" errors,
>> meaning that the received page does not match the expected content
>> (I'm testing a static page):
>>
>>
>
> That's consistent with what I see:
> If I run:
> #./semtimedop 100 100&
> #./semtimedop 100 100&
> #./semtimedop 100 100&
> #./semtimedop 100 100&
>
> (i.e.: 4 times the attached test app concurrently), then the system
> sometimes locks up for 10..20 seconds:
> The keyboard is unresponsive, not even the numlock key is processed (i.e.:
> the LED does not change anymore).
> After 10 or 20 seconds, the keyboard reacts again (both to <enter> and to
> Num Lock)
> The stock Fedora 13 kernel (2.6.33.5) does not exhibit this behavior
> The load average is 300 or so, that's expected.

Confirmed here: your test program freezes the system for a while under
2.6.35-rc3, while vanilla 2.6.34 copes fine.
sysrq-t was responsive during the freeze, so I took a snapshot during
it, file is attached.

> I have no idea why and how to debug the behavior.
> # CONFIG_PREEMPT_NONE is not set
> CONFIG_PREEMPT_VOLUNTARY=y
> # CONFIG_PREEMPT is not set

My kernel has PREEMPT enabled.

Luca
[unhandled content-type:application/x-gzip]
\
 
 \ /
  Last update: 2010-06-26 18:49    [W:0.097 / U:0.852 seconds]
©2003-2014 Jasper Spaans. Advertise on this site