lkml.org 
[lkml]   [2010]   [Jun]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/9] oom: cleanup has_intersects_mems_allowed()
On Mon, 21 Jun 2010, KOSAKI Motohiro wrote:

> > I disagree that the renaming of the variables is necessary, please simply
> > change the while (tsk != start) to use while_each_thread(tsk, start);
>
> This is common naming rule of while_each_thread(). please grep.
>

I disagree, there's no sense in substituting variable names like "tsk" for
`p' and removing a very clear and obvious "start" task: it doesn't improve
code readability.

I'm in favor of changing the while (tsk != start) to
while_each_thread(tsk, start) which is very trivial to understand and much
more readable than while_each_thread(p, tsk). With the latter, it's not
clear whether `p' or "tsk" is the iterator and which is the constant.


\
 
 \ /
  Last update: 2010-06-21 22:13    [W:0.083 / U:0.984 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site