lkml.org 
[lkml]   [2010]   [Jun]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] power: Rename get_current to fix build failure / name conflict
On Mon, Jun 14, 2010 at 05:12:22PM +0200, Peter Huewe wrote:
> Am Donnerstag 13 Mai 2010 07:27:28 schrieb Mike Rapoport:
> > Peter Huewe wrote:
> > > From: Peter Huewe <peterhuewe@gmx.de>
> > >
> > > This patch changes the name of get_current function pointer to
> > > get_battery_current to resolve a name conflict with the get_current
> > > macro defined in current.h.
> > >
> > > This conflict resulted in a build-failure[1] for the sh4 arch
> > > allyesconfig which is resolved by this patch.
> > >
> > > To be consistent the other function pointers (_voltage,_capacity) were
> > > renamed too.
> > >
> > > Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
> > Acked-by: Ryan Mallon <ryan@bluewatersys.com>
> > Acked-by: Mike Rapoport <mike@compulab.co.il>
>
> Unfortunately this build-failure still exists, in Linux-next and hit Linus'
> Tree :/
>
> References:
> http://kisskb.ellerman.id.au/kisskb/buildresult/2709436/
> http://kisskb.ellerman.id.au/kisskb/buildresult/2687686/

Thanks for the patch.

As this is not a 2.6.35 regression, and only affects just
a few embedded platforms, I think this can wait for the next
merge window.

So, applied to battery-2.6.git (for -next).

--
Anton Vorontsov
email: cbouatmailru@gmail.com
irc://irc.freenode.net/bd2


\
 
 \ /
  Last update: 2010-06-14 17:45    [from the cache]
©2003-2011 Jasper Spaans