[lkml]   [2010]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC] [PATCH 1/2] mmc: split mmc_sd_init_card()
Thanks for your review!

On Fri, May 28, 2010 at 02:40:27PM -0700, Andrew Morton wrote:
> On Tue, 25 May 2010 18:10:28 +0200 (CEST)
> Micha__ Miros__aw <> wrote:
> > This is needed to avoid code duplication in SD-combo support.
> hm. Perhaps you could have told us a bit more about it than this.
> > +int mmc_sd_get_cid(struct mmc_host *host, u32 ocr, u32 *cid)
> > +int mmc_sd_get_csd(struct mmc_host *host, struct mmc_card *card)
> > +int mmc_sd_setup_card(struct mmc_host *host, struct mmc_card *card,
> > +unsigned mmc_sd_get_max_clock(struct mmc_card *card)
> > +void mmc_sd_go_highspeed(struct mmc_card *card)
> These are global symbols, but they are not exported to (other) modules.
> That's odd. I'd have expected to see them either `static' or

This is all contained in mmc_core.ko and needs not be exported to other
modules. A SD-combo card is a SD (memory) and SDIO in one package - the
only changes needed are in initialization sequence, after which both
parts are mostly independent.

> I'll take the lack of a signed-off-by: and the "RFC" as signal to not
> apply these patches.

I would like for this to get tested by other people first, but it looks
like not many kernel developers use SD combo cards.

I'll resend the patches after applying your suggestions from the other

Best Regards,
Michał Mirosław

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2010-05-31 18:01    [W:0.055 / U:16.588 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site