lkml.org 
[lkml]   [2010]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] mac8390: change an error return code and some cleanup, take 4

On Mon, 31 May 2010, David Miller wrote:

> From: fthain@telegraphics.com.au
> Date: Mon, 31 May 2010 21:07:09 +1000 (EST)
>
> > Apparently David now wants me to submit this again --
> >
> > if (ei_debug)
> > pr_debug(...)
> >
> > David, if that code is acceptable, please let me know.
>
> The only thing I care about is at the moment that you don't do something
> that ends up dropping the pr_fmt prefix.
>
> The pr_fmt define at the beginning of the driver is for nothing if we
> end up adding exceptions that end up eliding it for no good reason.
> And that's what your patch was doing.
>

Since you have rejected my most recent patch submission, which uses pr_fmt
explicitly, I imagine that what you are trying to say here is that only
pr_debug or pr_info are acceptable.

Now, so that we don't have to go through pointless resubmission
iterations, can you tell me which of the following you prefer:

if (ei_debug)
pr_debug(...)
OR

if (ei_debug)
pr_info(...)
Thanks.

Finn


\
 
 \ /
  Last update: 2010-05-31 14:57    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site