lkml.org 
[lkml]   [2010]   [May]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCHv4 01/17] VFS: introduce helpers for the s_dirty flag
From
Date
On Fri, 2010-05-28 at 14:17 -0700, Andrew Morton wrote:
> On Fri, 28 May 2010 22:14:32 +0100
> Al Viro <viro@ZenIV.linux.org.uk> wrote:
>
> > On Fri, May 28, 2010 at 01:23:18PM -0700, Andrew Morton wrote:
> >
> > > A more conventional and superior naming scheme is
> > > subsystemid_specific_function_identifier(). eg, bio_add_page() instead
> > > of add_page_to_bio().
> > >
> > > So these want to be sb_mark_dirty(), etc.
> > >
> > > Being very old code written by very yound people, the VFS kinda ignores
> > > that convention, but it doesn't hurt to use it for new code.
> > >
> > > Feel free to ignore me if that's too much of a PITA ;)
> >
> > The real issue is that it's almost certainly an overdesign. Let's
> > get rid of the bogus uses first and figure out what's happening in
> > what remains, OK?
>
> That would be good.

Yes, I just mechanically introduced the wrappers to all FS-es. But as
per Al's request, I am going to try looking at how FSwe use it and
validate the usage. It'll take some time as this stuff is my background
task. Will see.

> > I have no problems with doing such wrappers, but if we touch every
> > place using ->s_dirt anyway, let's at least take a good look at them.
>
> When adding wrappers we should also rename ->s_dirt (say, to __s_dirt)
> to catch out any unconverted code.

Right, I did this in the following patch:
[PATCHv4 16/17] VFS: rename s_dirt to s_dirty

I thought that adding a leading '_' is not very neat, so added 'y' at
the end.

--
Best Regards,
Artem Bityutskiy (Артём Битюцкий)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2010-05-29 10:15    [from the cache]
©2003-2011 Jasper Spaans