lkml.org 
[lkml]   [2010]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: No mixers on ATI RS780 Azalia
    At Wed, 26 May 2010 14:21:59 +0200 (CEST),
    Jan Engelhardt wrote:
    >
    >
    > On Wednesday 2010-05-26 14:10, Takashi Iwai wrote:
    > >> /proc/asound/cards:
    > >> 0 [SB ]: HDA-Intel - HDA ATI SB
    > >> HDA ATI SB at 0xf0500000 irq 16
    > >> 1 [HDMI]: HDA-Intel - HDA ATI HDMI
    > >> HDA ATI HDMI at 0xf0110000 irq 19
    > >>
    > >> The soundcard responsible for the internal speaker is the 01:05.1/"HDMI"
    > >> one.
    > >
    > >Hmm? HDMI output as the "internal" speaker is abnormal.
    > >
    > >> Under Windows XP, I see the following mixer elements for it:
    > >>
    > >> * Master Volume
    > >> * Wave
    > >> * SW Synth
    > >> * CD Player
    > >>
    > >> Subsequently, there is sound (once I bump the volumes on these).
    > >
    > >There are definitely for the onboard sound, not for HDMI.
    >
    > The "SB" card has many more mixers (counting 10) and Windows XP also
    > shows about that many for SB. But neither in Linux nor Windows does
    > the SB card have any effect; I do have to turn the bars of the "HDMI"
    > one.
    >
    > Abnormal, well. It's (semi-)embedded, what did you expect.

    Wow, then is the HDMI cable connected inside the device?

    Anyway, "IEC958 Playback Switch" should be turned on for HDMI.

    % amixer -c1 IEC958 on

    Another issue is that HDMI audio is always through the video chip,
    thus the audio stuff is also controlled by the video driver.
    IIRC, ATI fglrx has a certain level of support for HDMI audio, but not
    sure about other drivers.


    Takashi


    \
     
     \ /
      Last update: 2010-05-26 14:41    [W:0.031 / U:31.864 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site