[lkml]   [2010]   [May]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH 07/37] lmb: Add lmb_find_area()
    On Fri, 2010-05-14 at 16:08 -0700, Yinghai wrote:
    > how about
    > lmb_reserve_area ==> lmb_reserve_range
    > lmb_free_area ==> lmb_free_range

    I completely fail to see why you still need those two. They are exactly
    the same thing as lmb_reserve() and lmb_free(), just with a slightly
    different prototype.

    > or leave them that way, later replace them lmb_reserve and lmb_free
    > one by one?

    Nah, if you have some use of the wrappers to ease the transition from
    the existing x86 code, then just make up a couple of inline wrappers
    somewhere inside the x86 code. You may not even want to call it
    lmb_* at all...

    But here, I'll let Thomas and Peter decide what to do, it's really
    x86 stuff at this stage. I don't want to see two subtlely different
    APIs at the LMB level doing the same thing.


     \ /
      Last update: 2010-05-17 02:53    [W:0.032 / U:37.788 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site