lkml.org 
[lkml]   [2010]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Marvell eSATA - 88SE6121 on Asus M3A79-T Deluxe - not in AHCI
Hi Jeff,

On 05/11/2010 05:09 PM, Jeff Garzik wrote:
> On 05/11/2010 02:28 PM, Phil Turmel wrote:
>> On 05/11/2010 01:21 PM, Phil Reynolds wrote:
>>> Quoting "Phil Turmel"<pturmel-kernel@turmel.org>:
>>>
>>>> I have a similar chipset in my office server: 88SE6145. If yours
>>>> can run
>>>> in AHCI mode, you just need "ahci.marvell_enable=1" on your kernel
>>>> command
>>>> line, or "options ahci marvell_enable=1" in your modprobe.conf. (I
>>>> have
>>>> ahci built-in, and no initramfs, so I put the option in my grub.conf.)
>>>
>>> Neither works for me unfortunately.
>>>

[snip /]

> sata_mv is not related to this hardware.
>
> pata_marvell works with 6101/6121/6141/6145 PATA ports.
>
> ahci works with 6101/6121/6141/6145 SATA ports, with marvell_enable=1.
>
> Jeff

I think you might have me (Phil T) confused with the original poster, Phil
Reynolds [1].

I have working SATA hotplug on my 88SE6145 w/ the ahci driver and
marvell_enable=1. The OP, Phil R., has an 88SE6121 that has been running
with the Marvell driver, without hotplug. Neither of us cares about the
PATA ports. Phil R. wants hotplug, but has not successfully enabled
marvell support in the ahci driver.

I've suggested Phil R. post his dmesg, lspci, and config, so we can figure out
what's going on.

Did I miss something else?

Phil

[1] http://marc.info/?l=linux-kernel&m=127341691613147&w=2


\
 
 \ /
  Last update: 2010-05-12 09:53    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site