lkml.org 
[lkml]   [2010]   [Apr]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 10/11] drivers/char/mem.c: Rename dev_info to bdi
Date
There is a macro called dev_info that prints struct device specific
information. Having variables with the same name can be confusing and
prevents conversion of the macro to a function.

Rename the existing dev_info variables to something else in preparation
to converting the dev_info macro to a function.

Signed-off-by: Joe Perches <joe@perches.com>
---
drivers/char/mem.c | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/char/mem.c b/drivers/char/mem.c
index 1f3215a..cb1d642 100644
--- a/drivers/char/mem.c
+++ b/drivers/char/mem.c
@@ -839,7 +839,7 @@ static const struct memdev {
const char *name;
mode_t mode;
const struct file_operations *fops;
- struct backing_dev_info *dev_info;
+ struct backing_dev_info *bdi;
} devlist[] = {
[1] = { "mem", 0, &mem_fops, &directly_mappable_cdev_bdi },
#ifdef CONFIG_DEVKMEM
@@ -873,8 +873,8 @@ static int memory_open(struct inode *inode, struct file *filp)
return -ENXIO;

filp->f_op = dev->fops;
- if (dev->dev_info)
- filp->f_mapping->backing_dev_info = dev->dev_info;
+ if (dev->bdi)
+ filp->f_mapping->backing_dev_info = dev->bdi;

if (dev->fops->open)
return dev->fops->open(inode, filp);
--
1.7.0.3.311.g6a6955


\
 
 \ /
  Last update: 2010-04-05 21:11    [from the cache]
©2003-2011 Jasper Spaans