[lkml]   [2010]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/6] change alloc function in pcpu_alloc_pages
On 04/19/2010 12:54 AM, Minchan Kim wrote:
>> alloc_pages is the same as alloc_pages_any_node so why have it?
> I don't want to force using '_node' postfix on UMA users.
> Maybe they don't care getting page from any node and event don't need to
> know about _NODE_.

Yeah, then, remove alloc_pages_any_node(). I can't really see the
point of any_/exact_node. alloc_pages() and alloc_pages_node() are
fine and in line with other functions. Why change it?

>> Why remove it? If you want to get rid of -1 handling then check all the
> alloc_pages_node have multiple meaning as you said. So some of users
> misuses that API. I want to clear intention of user.

The name is fine. Just clean up the users and make the intended usage
clear in documentation and implementation (ie. trigger a big fat
warning) and make all the callers use named constants instead of -1
for special meanings.



 \ /
  Last update: 2010-04-18 23:21    [W:0.094 / U:15.396 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site