lkml.org 
[lkml]   [2010]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/6] KVM MMU: reduce kvm_mmu_page size


Avi Kivity wrote:
> On 04/12/2010 11:05 AM, Xiao Guangrong wrote:
>> 'multimapped' and 'unsync' in 'struct kvm_mmu_page' are just indication
>> field, we can use flag bits instand of them
>>
>> @@ -202,9 +202,10 @@ struct kvm_mmu_page {
>> * in this shadow page.
>> */
>> DECLARE_BITMAP(slot_bitmap, KVM_MEMORY_SLOTS +
>> KVM_PRIVATE_MEM_SLOTS);
>> - int multimapped; /* More than one parent_pte? */
>> int root_count; /* Currently serving as active root */
>> - bool unsync;
>> + #define MMU_PAGE_MULTIMAPPED 0x1 /* More than one
>> parent_pte? */
>> + #define MMU_PAGE_UNSYNC 0x2
>> + unsigned int flags;
>> unsigned int unsync_children;
>> union {
>>
>
> Please just use bool for multimapped. If we grow more than 4 flags, we
> can use 'bool flag : 1;' to reduce space while retaining readability.
>

Yeah, good idea, i'll fix it in the next version

Thanks,
Xiao


\
 
 \ /
  Last update: 2010-04-12 13:17    [W:0.096 / U:0.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site