lkml.org 
[lkml]   [2010]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: mmotm boot panic bootmem-avoid-dma32-zone-by-default.patch
Hello Yinghai,

On Fri, Mar 05, 2010 at 10:41:56AM -0800, Yinghai Lu wrote:
> On 03/04/2010 09:17 PM, Greg Thelen wrote:
> > On Thu, Mar 4, 2010 at 7:21 PM, Johannes Weiner <hannes@cmpxchg.org> wrote:
> >> On Thu, Mar 04, 2010 at 01:21:41PM -0800, Greg Thelen wrote:
> >>> On several systems I am seeing a boot panic if I use mmotm
> >>> (stamp-2010-03-02-18-38). If I remove
> >>> bootmem-avoid-dma32-zone-by-default.patch then no panic is seen. I
> >>> find that:
> >>> * 2.6.33 boots fine.
> >>> * 2.6.33 + mmotm w/o bootmem-avoid-dma32-zone-by-default.patch: boots fine.
> >>> * 2.6.33 + mmotm (including
> >>> bootmem-avoid-dma32-zone-by-default.patch): panics.
> ...
> >
> > Note: mmotm has been recently updated to stamp-2010-03-04-18-05. I
> > re-tested with 'make defconfig' to confirm the panic with this later
> > mmotm.
>
> please check
>
> [PATCH] early_res: double check with updated goal in alloc_memory_core_early
>
> Johannes Weiner pointed out that new early_res replacement for alloc_bootmem_node
> change the behavoir about goal.
> original bootmem one will try go further regardless of goal.
>
> and it will break his patch about default goal from MAX_DMA to MAX_DMA32...
> also broke uncommon machines with <=16M of memory.
> (really? our x86 kernel still can run on 16M system?)
>
> so try again with update goal.

Thanks for the patch, it seems to be correct.

However, I have a more generic question about it, regarding the future of the
early_res allocator.

Did you plan on keeping the bootmem API for longer? Because my impression was,
emulating it is a temporary measure until all users are gone and bootmem can
be finally dropped.

But then this would require some sort of handling of 'user does not need DMA[32]
memory, so avoid it' and 'user can only use DMA[32] memory' in the early_res
allocator as well.

I ask this specifically because you move this fix into the bootmem compatibility
code while there is not yet a way to tell early_res the same thing, so switching
a user that _needs_ to specify this requirement from bootmem to early_res is not
yet possible, is it?

> Reported-by: Greg Thelen <gthelen@google.com>
> Signed-off-by: Yinghai Lu <yinghai@kernel.org>
>
> ---
> mm/bootmem.c | 28 +++++++++++++++++++++++++---
> 1 file changed, 25 insertions(+), 3 deletions(-)
>
> Index: linux-2.6/mm/bootmem.c
> ===================================================================
> --- linux-2.6.orig/mm/bootmem.c
> +++ linux-2.6/mm/bootmem.c
> @@ -170,6 +170,28 @@ void __init free_bootmem_late(unsigned l
> }
>
> #ifdef CONFIG_NO_BOOTMEM
> +static void * __init ___alloc_memory_core_early(pg_data_t *pgdat, u64 size,
> + u64 align, u64 goal, u64 limit)
> +{
> + void *ptr;
> + unsigned long end_pfn;
> +
> + ptr = __alloc_memory_core_early(pgdat->node_id, size, align,
> + goal, limit);
> + if (ptr)
> + return ptr;
> +
> + /* check goal according */
> + end_pfn = pgdat->node_start_pfn + pgdat->node_spanned_pages;
> + if ((end_pfn << PAGE_SHIFT) < (goal + size)) {
> + goal = pgdat->node_start_pfn << PAGE_SHIFT;
> + ptr = __alloc_memory_core_early(pgdat->node_id, size, align,
> + goal, limit);
> + }
> +
> + return ptr;

I think it would make sense to move the parameter check before doing the
allocation. Then you save the second call.

And a second nitpick: naming the inner function __foo and the outer one ___foo seems
confusing to me. Could you maybe rename the wrapper? bootmem_compat_alloc_early() or
something like that?

Thanks,
Hannes


\
 
 \ /
  Last update: 2010-03-06 01:01    [W:0.103 / U:0.128 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site