lkml.org 
[lkml]   [2010]   [Mar]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: kmemleak_scan_area
Date
Sachin Pandhare <sachinpandhare@gmail.com> wrote:
> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
> well as a function.
> e.g.:
> - struct kmemleak_scan_area {
> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>
> Do you think it is a good to have it like that?

Does it cause any problems? I think C has different namespaces for types
and functions, so they should not collide. I agree that from a
readability perspective, it would be better if they are named
differently (like kmemleak_scan_area_node :)).

--
Catalin


\
 
 \ /
  Last update: 2010-03-31 14:09    [W:0.310 / U:0.128 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site