lkml.org 
[lkml]   [2010]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PWM PATCH 2/5] Emulates PWM hardware using a high-resolution timer and a GPIO pin
From
Date

11.02.2010, в 23:58, Pavel Machek написал(а):

> On Thu 2010-02-11 14:35:14, Bill Gatliff wrote:
>> Pavel Machek wrote:
>>>> +static void
>>>> +gpio_pwm_work (struct work_struct *work)
>>>> +{
>>>> + struct gpio_pwm *gp = container_of(work, struct gpio_pwm, work);
>>>> +
>>>> + if (gp->active)
>>>> + gpio_direction_output(gp->gpio, gp->polarity ? 1 : 0);
>>>> + else
>>>> + gpio_direction_output(gp->gpio, gp->polarity ? 0 : 1);
>>>> +}
>>>>
>>>
>>> ...polarity ^ active ?
>>>
>>
>> ... except that if polarity and/or active are >1, I don't send the
>> values 1 or 0 to gpio_direction_output. I don't know if the API is
>> specifically intended to accept nonzero values that are greater than 1.
>
> !polarity ^ !active ? :-).


One the one hand that wouldn't be 100% right because according to ANSI C !(0) is just != 0 but no one says it is 1.
On another hand as far as I can see polarity and active fields are both defined as "unsigned long <name> :1" in the gpio_pwm structure. And that means they can be equal only to 0 or 1. So simple (polarity ^ active) is the right choice as far as the original decision.
What is strange for me is that resulting control flow is not right representation of what is happening. I mean that actually one should perform a call to an external function with an argument that depends on values of two variables. While this code is equal to call function A if some variable is not equal to 0 with argument depending on value of some other variable else call function B. I hope you understood what I'm trying to say.
Therefore even if you wish to leave if statement (not sure that gcc would optimize that) the right control flow representation should be the following:
.....
if (gp->active)
value = ((gp->polarity)?1:0);
else
value = ((gp->polarity)?0:1);

gpio_direction_output(gp->gpio, value);
.....

The second strange thing is "unsigned long <name>:1". I'm not sure but as far as I can remember the right way to define several-bits field is "int <name>:1". But I might be mistaken.


Best regards. Stas.



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2010-02-12 08:25    [W:1.993 / U:0.860 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site