lkml.org 
[lkml]   [2010]   [Dec]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 02/10] xen/p2m: change p2m_missing_* to p2m_identity_*
On 12/22/2010 06:59 AM, Konrad Rzeszutek Wilk wrote:
> On Tue, Dec 21, 2010 at 02:41:23PM -0800, Jeremy Fitzhardinge wrote:
>> On 12/21/2010 01:37 PM, Konrad Rzeszutek Wilk wrote:
>>> From: Konrad Rzeszutek Wilk <konrad@kernel.org>
>>>
>>> We are going to alter how we think about P2M. Most of the
>>> P2M contains MFN, and areas that are not populated are
>>> considered to be "missing". Missing means that the PFN
>>> is either not set for this guest (not have that much memory
>>> allocated) or is under the balloon driver ownership.
>>>
>>> We are instead now going to think of those not populated
>>> areas as "identity." Meaning that that the PFN for which
>>> we would get the p2m_identity we will provide the the PFN
>>> value back instead of P2M_MISSING. Essentially treating
>>> those regions as PFN==MFN.
>>>
>> This renames missing -> identity, but does it actually change the
>> functionality? Doesn't it just leave it being misnamed? It would
>> probably be better to fold in the actual identity implementation as well.
> You sure? It would be a lot of changes in one patch. This patch is
> a nop - so no functional changes except the name change.
>
> Let me annotate the git tree to mention this.

Yeah, I'm in two minds. I like small single-purpose patches, but the
rename really does leave things v. misnamed. I guess it doesn't really
matter for one commit, so long as its still bisectable (and the commit
comment makes it clear that the name is misleading).

>>> mid_mfn_mfn = virt_to_mfn(mid_mfn);
>>> - if (cmpxchg(top_mfn_p, missing_mfn, mid_mfn_mfn) != missing_mfn)
>>> + if (cmpxchg(top_mfn_p, identity_mfn, mid_mfn_mfn) !=
>>> + identity_mfn)
>> Don't wrap this.
> Checkpatch.pl was unhappy without it. I can ignore this.

Checkpatch is generally wrong on the subject of long lines.

J



\
 
 \ /
  Last update: 2010-12-22 21:39    [from the cache]
©2003-2011 Jasper Spaans