lkml.org 
[lkml]   [2010]   [Dec]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [alsa-devel] [RFC/PATCH v6 03/12] media: Entities, pads and links
    Date
    Hi Clemens,

    On Tuesday 14 December 2010 14:49:15 Clemens Ladisch wrote:
    > Laurent Pinchart wrote:
    > > On Tuesday 14 December 2010 13:40:21 Hans Verkuil wrote:
    > >> > On Monday 13 December 2010 17:10:51 Clemens Ladisch wrote:
    > >> >> * Entity types
    > >> >>
    > >> >> TYPE_NODE was renamed to TYPE_DEVICE because "node" sounds like a
    > >> >> node in a graph, which does not distinguish it from other entity
    > >> >> types because all entities are part of the topology graph. I chose
    > >> >> "device" as this type describes entities that are visible as some
    > >> >> device node to other software.
    > >> >
    > >> > What this type describes is a device node. Both NODE and DEVICE can be
    > >> > confusing in my opinion, but DEVICE_NODE is a bit long.
    > >>
    > >> What about DEVNODE? I think that would be a good alternative.
    > >
    > > Fine with me. Clemens, any opinion on that ?
    >
    > Fine with me too.

    OK I'll use that name.

    > > > >> TYPE_EXT describes entities that represent some interface to the
    > > > >> external world, TYPE_INT those that are internal to the entire
    > > > >> device. (I'm not sure if that distinction is very useful, but
    > > > >> TYPE_SUBDEV seems to be an even more meaningless name.)
    > > > >
    > > > > SUBDEV comes from the V4L2 world, and I agree that it might not be a
    > > > > very good name.
    > > >
    > > > SUBDEV refers to a specific type of driver. Within the v4l world it is
    > > > well defined. So I prefer to keep this. Perhaps some additional
    > > > comments or documentation can be added to clarify this.
    > >
    > > Should this be clarified by using V4L2_SUBDEV instead then ?
    >
    > If the "SUBDEV" concept doesn't exist outside V4L, that would indeed be
    > better.
    >
    > I don't want to rename things that come out of existing frameworks; this
    > naming discussion makes sense only for those entity (sub)types that can
    > be shared between them. Are there any, besides jacks?

    Some entities like TV tuners play a dual audio/video role. I'm not sure how to
    handle them, I lack experience in that field.

    > > What about ALSA entities, should they use MEDIA_ENTITY_TYPE_ALSA_* ?
    >
    > The entity types representing ALSA devices are already named "ALSA".

    I was talking about the INT_* types. They're ALSA-specific, but have no ALSA
    in the type name.

    --
    Regards,

    Laurent Pinchart


    \
     
     \ /
      Last update: 2010-12-15 00:51    [W:0.028 / U:30.404 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site